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Stellaris® Development and Evaluation Kits for 
Red Suite 
The Stellaris Development and Evaluation Kits provide a low-cost way to start designing with 
Stellaris microcontrollers using Code Red Technologies’ Red Suite development tools. The 
boards can function as either a complete evaluation target or as a debugger interface to any 
external Stellaris device.   

Requirements 
 You have a PC with a USB interface, running Microsoft® Windows XP (SP2 or greater) 

or Vista 
 You have the Stellaris Evaluation Kit Documentation and Software CD or the standalone 

Code Red CD found in the Development Kit 
 
CAUTION: There is a known electrical issue with the FT2232 device that is used in the  
on-board In Circuit Debug Interface (ICDI). Some USB hubs can cause the device to 
misbehave, with symptoms ranging from failed enumeration to corrupt data transfers. If you 
experience trouble when using the on-board ICDI, try connecting the USB cable directly to 
one of the USB ports on your PC or laptop. 
 

Red Suite 
This quickstart shows you how to install the Red Suite development tool and how to use it to 
build and run an example application on your Stellaris Evaluation Board. 

Step 1: Install Red Suite  
1. Insert the Evaluation Kit Documentation and Software CD or the standalone Code Red 

CD into the CD-ROM drive of your computer. If Autoplay is enabled on your PC, the 
index.htm file is opened automatically in your default web browser. If Autoplay is not 
enabled, use Windows Explorer to open the CD manually. 

2. With the Evaluation Kit CD, click the Tools button and then click the Code Red logo 
to start the setup program. If the setup program does not start, use Windows Explorer 
to view the files on the CD and double-click the red_suite_n.n.n.exe file located in the 
“Tools\Code Red\” directory.  
 
With the standalone CD, follow the installer dialog. 
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3. Follow the instructions in the Red Suite installation program. When you get to the 
Debug Driver Selection window, deselect the “NXP LPC-Line drivers” by clicking the 
checkbox. After you have clicked the checkbox, the window should look like this: 

 

4. Click the Next button to continue with the installation. 

5. Red Suite continues to install into a single directory of your choice. Unlike many 
software packages, Red Suite does not install or use any keys in the Windows 
Registry, or use or modify any environment variables (including PATH), which results 
in a clean installation that does not interfere with anything else on your PC. 
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Step 2: Install the StellarisWare® Package 

A full set of C-based peripheral drivers is provided, covering all peripherals and functionality 
of the Stellaris devices. The StellarisWare package includes various example applications 
with project files for all major tool vendors that support Stellaris, including Code Red. To 
install StellarisWare components, follow these steps: 

1. Navigate to the Tools tab on the Evaluation Kit Documentation and Software CD, or 
to the Software tab on the Development Kit Documentation and Software CD. 
 
NOTE: If you are navigating the CD using Windows Explorer (or a similar 
application), go to the Tools/StellarisWare or Software/StellarisWare directories. 

2. Click on the 'Install' link next in the StellarisWare section (under Tools or Software) of 
the CD and run the StellarisWare installer. If you prefer to manually install 
StellarisWare, the installer is a self-extracting zip file that is located in the 
Tools/StellarisWare directory. You can use a zip file extraction utility such as WinZip 
to manually extract the contents. 

3. To view the StellarisWare documentation, navigate to the installation directory and 
click on the Stellaris Software User’s Guide PDF. 

 

Step 3: Start Red Suite and Open a Workspace 
1. Start the Red Suite IDE by selecting it from the Windows Start menu or clicking the 

Red Suite 2 icon installed on your desktop. When the IDE loads, it will ask you where 
to open the workspace folder: 

red_suite\workspace|

 

2. The Workspace launcher defaults to the following path: 
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 C:\Documents and Settings\<username>\My Documents\red_suite\workspace 

Click OK to use this default workspace location. 

3. If this is the first time you have run the Red Suite IDE, a dialog box may appear like 
the one shown below. If the dialog appears, click OK to continue. 

 

 

4. The Red Suite IDE now opens with an empty workspace. Go to “Help > Product 
activation” to request and activate your evaluation license. 
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5. Follow the instructions to obtain and activate your evaluation license. 

 
Important: For the most recent version of the StellarisWare workspaces, check the 
www.ti.com/stellaris web site for the latest software updates. 
 

Step 4: Import and Build Example Projects 
1. Select the “Import…” option from the File menu in Red Suite. 

 5 

http://www.ti.com/stellaris


Q U I C K S T A R T  –  C O D E  R E D  
T E C H N O L O G I E S  
 

Rev. 1.9 

 

 6 



Q U I C K S T A R T  –  C O D E  R E D  
T E C H N O L O G I E S  
 

Rev. 1.9 

2. Another dialog box appears to let you select what to import. Click “General” to 
expand all of the options and then click “Import project(s) from XML description.” 
Click the Next button when you are finished. 
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3. On the next screen, browse to locate an XML file. The XML description files are 
located in the StellarisWare installation from Step 2, which by default is  
C:/StellarisWare. From here, the XML file is located in: 
 
StellarisWare\boards\{board_name} 
 
Select the cr_workspace.xml file and click on “Open”.  Then click “Finish”. 

4. A new window opens containing all of the available projects for your board. You can 
import them all to your workspace or select only the examples that you want. If you 
choose to select only a few examples, the top items must also be imported. These are 
the StellarisWare library projects, third-party applications, and utilities directories that 
some projects have dependencies on. In this example, you will only import the “hello” 
project. 

 

With the projects selected, click “OK.”  The projects are then imported to your workspace 
and built. 
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5. You will now see the projects listed in the Project Explorer. The projects will 
automatically start to build. Wait for the projects to finish building before continuing.  

 

6. To rebuild an individual project, select the project you want to build by clicking an 
item in the Project Explorer list.  From the “Build and Settings” section of the 
Quickstart Panel in the bottom left of the Red Suite window, click “Build project 
‘<name>’ for Debug.” If this option is not visible, expand the “Build and Settings” 
section by clicking on the downward pointing arrows to the right of the title.  

 

Step 5: Debugging a Project 

1. You will have several example projects from which to choose for your evaluation 
board. For an example, start with the hello project. Select the “hello” project in the 
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Project Explorer pane then click “Debug project ‘hello’” from the “Debug and Run” 
section of the Quickstart Panel. 
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2. You will be asked to select the executable to debug. Choose “Debug/hello.axf” then 
press OK. 

 

3. You may get the Windows Security Alert pop-up shown below. Click the Unblock 
button to continue. This is necessary for proper operation of the debugging interface. 

 
 

4. If this is the first time you have used the debugger, Red Suite will also prompt you to 
confirm your prospective switch. Click the Yes button to continue. 

 

 11 



Q U I C K S T A R T  –  C O D E  R E D  
T E C H N O L O G I E S  
 

Rev. 1.9 

 
 

 12 



Q U I C K S T A R T  –  C O D E  R E D  
T E C H N O L O G I E S  
 

Rev. 1.9 

5. The Red Suite debugger automatically connects to your evaluation board, programs 
the flash, and runs to the beginning of the main() function. From here, you can 
examine and modify memory, program variables and processor registers, set 
breakpoints, step, and other typical debugging activities. To run the program, select 
“Resume” from the Run menu. 

 

 
 
6. The application starts running, and you should see the text “Hello World!” output to 

the display of the evaluation board. 

Step 6: Build and Run Additional Example Programs 
There are several additional example projects listed in workspace. If you would like to build 
another example project, follow the above instructions to import the different projects into the 
workspace. The quickstart application that came preloaded on the evaluation board is the 
qs_xxxxx project listed with the examples. 
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Creating a New Project  
Once you have gone through the StellarisWare example applications, you may want to create 
your own project to start development.  While you can always start with an existing, simple 
project, sometimes you may want to start fresh. 

The Code Red tools have a very nice project wizard that lets you create a variety of different 
project types, with all of the necessary hooks to StellarisWare.  It also completely sets up the 
debug interface so that all you need to do is start writing software, without worrying about 
setting up your project correctly. 

To add a new project to your workspace (assuming you’re still using the example described 
above), go to File > New > C Project. 

 

Red Suite will prompt you with a dialog box asking for the type of project you want to create.  
You’ll focus on the executable project types for this example.  In this list, you have 6 options 
for Stellaris microcontrollers.  The simplest one to start with is the “LMI StellarisWare 
Project” because it provides all of the necessary hooks to StellarisWare drivers. 
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Here, let’s create a new project called “my_project”.  If you click Next, the tool will give you 
the option to automatically set up the hooks into the StellarisWare Graphics Library and USB 
Library if you need them.  The default configuration (if you were to just click Finish instead 
of Next) sets all of these up for you. 
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Clicking Next again lets you choose whether to use DriverLib in ROM (if your device 
supports it), and if you would like to use a buffered (FIFO enabled) UART. 
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You can then select the name of your source directory and choose whether or not you’d like 
the tool to create a main.c file and startup code for you.  We suggest letting the tool do it to 
make it easy for you.  You can also choose to create both Debug and Release versions of your 
code. 

  

Lastly, you select the device you’re using.   
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With your project created, all you really need to do is add your code.  The main.c file created for you 
already sets up the system clock and includes the header files to use the System Control module of the 
DriverLib.  From here, you’re ready to go! 
 
Conclusion 

You have now installed the Red Suite development tools and used them to build and load an 
example application on your Stellaris Evaluation Board. From here, you can experiment with 
the debugger or start creating your own application using the projects as examples. Red Suite 
has many powerful features to help you develop embedded applications. For further 
information on Red Suite, start with the “Red Suite Quickstart Guide” installed with the Red 
Suite tools.  
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References 
The following references are included on the Stellaris Evaluation Kit Documentation and 
Software CD and are also available for download at www.ti.com/stellaris: 
 
 Stellaris Evaluation Kit User's Manual 

 StellarisWare Software, Order Number SW-LM3S 

 StellarisWare Peripheral Driver Library User’s Guide, Order Number SW-DRL-UG 

 In addition, the following website may be useful: 

 Code Red Technologies website at http://www.code-red-tech.com 
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